[FFmpeg-devel] AAC/RTP crash

Ronald S. Bultje rsbultje
Sat Mar 7 16:35:59 CET 2009

Hi Robert,

On Fri, Mar 6, 2009 at 7:49 PM, Robert Swain <robert.swain at gmail.com> wrote:
>>> 2009/1/15 Ronald S. Bultje<rsbultje at gmail.com>:
>>>> With the built-in decoder instead of faad, RTP streams containing AAC
>>>> data can crash ffplay. Example below:
>>>> $ ./ffplay rtsp://video.medinfo.ufl.edu/opeta/MS_all.mov
>>>> Program received signal EXC_BAD_ACCESS, Could not access memory.
>>>> Reason: KERN_PROTECTION_FAILURE at address: 0x000000e5
>>>> [Switching to process 28864 thread 0x7eab]
>>>> 0x001467e3 in aac_decode_frame (avccontext=???, data=???,
>>>> data_size=???, buf=???, buf_size=???) at libavcodec/aac.c:1493
>>>> 1493 ? ? ? ? ? ? ? ? ? ?if(che->ch[0].tns.present)
> Anyway, I tried the command line you pasted and I didn't observe any
> crash. I didn't see any video, just a black rectangle, and the audio was
> somewhat messed up. Can you still reproduce the issue?

Indeed, no more crash. The sound isn't what it should be though.
Appears to work fine with libfaad... Are you taking such bug reports?
I've found another one that plays fine with --enable-libfaad
--disable-decoders=aac as well, but not with our built-in decoder, and
giving me a lot of stdout:

$ ./ffplay rtsp://inet.orban.com/mp4.sdp
[aac @ 0x2034e00]SBR not implemented. Update your FFmpeg version to
the newest one from SVN. If the problem still occurs, it means that
your file has a feature which has not been implemented.

Is this being worked on? If not, might be a point where I start
looking at lavc (I first want the decoder LGPL before I touch it, btw,
I can chase Walken if you want and are confident we've done what he
asked for).


More information about the ffmpeg-devel mailing list