[FFmpeg-devel] 5.1 AAC on 0.5 branch

Justin Ruggles justin.ruggles
Mon Mar 9 23:39:11 CET 2009


Pascal Patry wrote:
> I've been testing a lot of content on the 0.5 branch for regressions directly in FFplay. I 
> found that AAC audio using multiple channels don't work properly.
> FFplay correctly sets 'request_channels' to 2, but it seems to still get 5 channels from 
> these streams.

request_channels is only a request, which the decoder does not have to
follow. whatever channels is set to is what the decoder should output,
and that is currently done correctly by the aac decoder. the issue is
that ffplay does not do any post-decoding dowmixing. ffmpeg uses the
audio_resample() API in libavcodec to do post-decoding (well, actually
pre-encoding) downmixing when it is supported.

> An example of that kind of content can be found here:
> http://movies.apple.com/movies/universal/the_incredible_hulk/the_incredible_hulk-tlr2_h1080p.mov
> Audio stream:
> Stream #0.1(eng): Audio: aac, 48000 Hz, 5.1, s16
> Stereo AAC streams are working perfectly. This is most likely a regression because an 
> older version of the AAC decoder is able to downmix this video to 2 channels.
> Is there any chance of getting that fixed for the release?

it's not likely. someone would need to either implement efficient
aac-specific dowmixing in the aac decoder or patch ffplay to use
audio_resample(). also, they would have to convince diego to accept
backporting it to the 0.5 branch, which would probably be more difficult
than doing the coding. ;)


More information about the ffmpeg-devel mailing list