[FFmpeg-devel] ffmpeg for bluefin bug

Adam Dershowitz, Ph.D., P.E. adershowitz
Tue Mar 17 21:40:36 CET 2009

On Mar 17, 2009, at 5:06 AM, Diego Biurrun wrote:

> On Mon, Mar 16, 2009 at 02:58:37PM -0700, Adam Dershowitz wrote:
>> I was trying to compile ffmpeg 0.5 on the Blackfin, with uclinux.  I
>> found a bug and then a fix.
>> I am using --enable-swscale and when it tries to link, I get a link
>> error:
>> libswscale.so undefined reference to  
>> '_sws_ff_bfin_yuv2rgb_get_func_ptr'
>> Sure enough this function is used in libswscale/yuv2rgb.c:
>> lines 461:
>> #if ARCH_BFIN
>>     if (c->flags & SWS_CPU_CAPS_BFIN)
>>         t = sws_ff_bfin_yuv2rgb_get_func_ptr(c);
>> #endif
>> But I greped through the code and I can't find that function defined
>> anywhere.  In fact, I only see it that single time in the code.
>> I asked around some and was told that:
>> ff_bfin_yuv2rgb_get_func_ptr  in yuv2rgb_bfin.c is the correct  
>> function.
>> So one of these needs to be changed so that they have the same name.
>> I am not sure if this is the best place to report this bug and fix.
>> If not, please let me know where might be a better place.
> Fixed.
> Diego
> _______________________________________________

Thanks....but.  Now ti compiles and starts to run on my BF527 EZkit  
board.  I get the normal startup message and I get info on the  
streams.  Before any frames get converted I get an "illegal  
instruction" and a core dump.
Any suggestions about this?  Given the above error it looks like no  
one has actually tested the blackfin specific code.  I had been  
running a much older version of ffmpeg from blackfin.uclinux.com that   
does run.
But this new one doesn't.  I have tried both with and without swscale  
with the same results.



More information about the ffmpeg-devel mailing list