[FFmpeg-devel] ffmpeg for bluefin bug

Adam Dershowitz, Ph.D., P.E. adershowitz
Thu Mar 19 00:57:16 CET 2009

On Mar 17, 2009, at 4:54 PM, Diego Biurrun wrote:

> On Tue, Mar 17, 2009 at 01:40:36PM -0700, Adam Dershowitz, Ph.D.,  
> P.E. wrote:
>> On Mar 17, 2009, at 5:06 AM, Diego Biurrun wrote:
>>> On Mon, Mar 16, 2009 at 02:58:37PM -0700, Adam Dershowitz wrote:
>>>> I was trying to compile ffmpeg 0.5 on the Blackfin, with  
>>>> uclinux.  I
>>>> found a bug and then a fix.
>>>> I am using --enable-swscale and when it tries to link, I get a link
>>>> error:
>>>> libswscale.so undefined reference to
>>>> '_sws_ff_bfin_yuv2rgb_get_func_ptr'
>>>> Sure enough this function is used in libswscale/yuv2rgb.c:
>>>> lines 461:
>>>> #if ARCH_BFIN
>>>>    if (c->flags & SWS_CPU_CAPS_BFIN)
>>>>        t = sws_ff_bfin_yuv2rgb_get_func_ptr(c);
>>>> #endif
>>>> But I greped through the code and I can't find that function  
>>>> defined
>>>> anywhere.  In fact, I only see it that single time in the code.
>>>> I asked around some and was told that:
>>>> ff_bfin_yuv2rgb_get_func_ptr  in yuv2rgb_bfin.c is the correct
>>>> function.
>>>> So one of these needs to be changed so that they have the same  
>>>> name.
>>>> I am not sure if this is the best place to report this bug and fix.
>>>> If not, please let me know where might be a better place.
>>> Fixed.
>> Thanks....but.  Now ti compiles and starts to run on my BF527 EZkit
>> board.  I get the normal startup message and I get info on the
>> streams.  Before any frames get converted I get an "illegal
>> instruction" and a core dump.
>> Any suggestions about this?
> Gather the relevant information and send us a bug report:
> http://www.ffmpeg.org/bugreports.html

I just registered and tried to.  But I keep getting an error when I  
click submit that says:
An error has occurred
A problem was encountered processing your request.  The tracker  
maintainers have been notified of the problem.

Am I doing something wrong, or is something wrong with the tracker?

>> Given the above error it looks like no one has actually tested the
>> blackfin specific code. I had been running a much older version of
>> ffmpeg from blackfin.uclinux.com that does run.
> Marc Hoffman, the author of the blackfin code in FFmpeg, used to work
> for Analog Devices, I'm pretty sure the code must have worked at some
> point on some machine.

I have also been talking to some people at blackfin.uclinux.org.  That  
site has a few people from AD who post (maybe support the site?).  I  
have not seen any posting from Hoffman in a while, so might not be  
working on this any longer.
But the current release of Linux on that site includes ffmpeg- 
svn-11114 and that version does compile and run.

>> But this new one doesn't.  I have tried both with and without swscale
>> with the same results.
> Then the bug may be in libavcodec instead of libswscale.

Sounds likely.  I have tried a few different input and output file  
types, and always get the same results. 

More information about the ffmpeg-devel mailing list