[FFmpeg-devel] [PATCH] G722 decoder

Diego Biurrun diego
Mon Mar 23 20:11:52 CET 2009

On Mon, Mar 23, 2009 at 12:01:42PM -0700, Baptiste Coudurier wrote:
> On 3/23/2009 11:14 AM, Diego Biurrun wrote:
> > On Mon, Mar 23, 2009 at 11:07:19AM -0700, Kenan Gillet wrote:
> >> On Mar 23, 2009, at 11:00 AM, Diego Biurrun wrote:
> >>
> >>> On Mon, Mar 23, 2009 at 10:22:06AM -0700, Kenan Gillet wrote:
> >>>> On a side note, I think the G722 patch [1] should be removed or at  
> >>>> least
> >>>> a warning about its incompatible license should be added in the wiki.
> >>>> Will gladly do it if a consensus is reached.
> >>> You don't have a wiki account?  Send me an email with the login name  
> >>> you want...
> >> I do, just wanted to ask what would be the best course of action.
> > 
> > Add a note about the license incompatibility of course.  So that the
> > next person does not stumble into the same trap you fell into.
> I'm prefectly fine in integrating a patch using LGPL v2.1 only.

It's nice that you are fine with it, but changing FFmpeg's license is
not acceptable.  If just one file is LGPL v2.1 only, all of FFmpeg
reverts to LGPL v2.1 only and becomes incompatible with (L)GPL v3

It's also clearly stated in point 1 of our development policy:



More information about the ffmpeg-devel mailing list