[FFmpeg-devel] [PATCH] G722 decoder

Diego Biurrun diego
Mon Mar 23 20:20:53 CET 2009

On Mon, Mar 23, 2009 at 02:13:13PM -0500, John Lange wrote:
> On Mon, 2009-03-23 at 11:48 -0400, David Conrad wrote:
> > >> while FFmpeg is LGPL 2.1 or later.
> > If you feel strongly about "or later" you probably shouldn't be using  
> > LGPL in the first place, since it includes a clause that explicitly  
> > allows relicensing to any newer version of the GPL that has been  
> > released.
> If that were the case, then the words "or later" would be irrelevant.

False.  With the "or later" clause, you can upgrade to a later LGPL
version.  Without it, you can only upgrade to a later GPL version.


More information about the ffmpeg-devel mailing list