[FFmpeg-devel] Flash Screen Video 2 samples?

Daniel Verkamp daniel
Wed Mar 25 09:01:44 CET 2009

On Wed, Mar 25, 2009 at 2:49 AM, Daniel Verkamp <daniel at drv.nu> wrote:
> On Wed, Mar 25, 2009 at 12:07 AM, Mike Melanson <mike at multimedia.cx> wrote:
>> compn wrote:
>>> On Tue, 24 Mar 2009 20:49:24 -0700, Mike Melanson wrote:
>>>> Daniel Verkamp wrote:
>>>>> Hi,
>>>>> Does anyone have any samples of Flash video files using the flashsv2
>>>>> codec? ?The only flashsv sample I could find in the mplayer samples
>>>>> archive is http://samples.mplayerhq.hu/FLV/flash_screen/screen.flv ,
>>>>> which uses version 1 of the screen codec.
>>>> None known to exist. Apparently, the only way that the flashsv2 codec
>>>> exists "in the wild" is when it is streamed by certain Adobe media servers.
>>>> I realize that this is a problem and I have been working on ways to
>>>> capture/contrive some samples for the open source community.
>>> tried rtmpdump? got urls?
>> This is moving up on my priority list since there is renewed interest due to
>> GSoC.
>>> :grumbles about supporting a codec with no samples while codecs with
>>> lots of samples get ignored:
>> As always, "patch welcome". :)
>> --
>> ? ?-Mike Melanson
> Attached:
> 1. ?Add new codec id for flashsv2 and hook it up in the FLV (de)muxer
> - this should be ok for inclusion as-is.
> 2. ?Temporary flashsv2 encoder - this is just a hacked-up version of
> the flashsv1 encoder that does not use any new v2 features; however,
> it *does not work*. ?I've tested a file produced by this encoder in JW
> Player with Flash Player (Windows) and it does not play any
> video (audio plays fine, as do files with flashsv1). ?I am fairly
> certain it does follow the SWF file format spec for v2, so maybe
> something is missing/incorrect in the spec. ?Also note that unchanged
> block support is disabled (with the || 1) just to be sure that case is
> not the problem; I was not sure from reading the spec whether the
> Format field in IMAGEBLOCKV2 is to be coded when DataSize == 0 (it
> appears that it should be).
> Thanks,
> -- Daniel Verkamp

The Makefile change is in the wrong patch (past my bedtime...)

Here is a small sample created with this encoder:

-- Daniel Verkamp

More information about the ffmpeg-devel mailing list