[FFmpeg-devel] [PATCH] G722 decoder

Diego Biurrun diego
Wed Mar 25 17:49:58 CET 2009

On Wed, Mar 25, 2009 at 08:41:01AM -0700, Baptiste Coudurier wrote:
> On 3/25/2009 6:16 AM, Diego Biurrun wrote:
> > On Tue, Mar 24, 2009 at 07:26:13PM -0700, Baptiste Coudurier wrote:
> >> As long as we distribute under LGPL v2.1, and that is what we do,
> >> we can distribute LGPL v2.1 only code.
> > 
> > We are most emphatically *not* distributing under LGPL v2.1.  We have an
> > explicit "or later" clause in all files.
> In all files, however the LGPL is pretty strict, mentioning the
> "library", not "file" contained in the library.

What is this ephemeral thing you call "library" if it is not the sum of
all files then?  The program's soul?

> >> Do you mean that a LGPLv3 project cannot "link" against FFmpeg LGPL v2.1
> >> only ?
> > 
> > No, I mean that they cannot grab FFmpeg and make it part of their
> > software, which is what most currently do. 
> No, you are wrong, this is what _mplayer_ do. I know people use to tell
> this in the past, to statically use on revision in their project, and
> this was a mistake.

It's not only MPlayer and it's completely irrelevant to this discussion.
We may approve or disapprove of the things people do, but they still
have a right to do so.

> Can you please stop talking about technical reason ?

Sure, let's leave the arguments aside and just flame for the heck of it


More information about the ffmpeg-devel mailing list