[FFmpeg-devel] How do I display I-frames only in H.264

Waters, Ralph rwaters
Sun May 3 23:22:48 CEST 2009

Hi All,

> I'm not sure of all the ffmpeg lists and how to properly use them, so
> if I am in the wrong area for this question, I would greatly
> appreciate being pointed to the right area, and thank you in advance.
> I was wondering if anyone has any clue on how to just display I-frames
> only for a H.264 stream. I have had an easy time of getting MPEG-4 to
> display I-frame only data by using the pCodexCtx->skip_frame =
> AVDISCARD_NONKEY And it works like a charm. For H.264 this variable
> doesn't seem to work, although I'm not sure why. My h.264 profile is
> baseline 3.1 and it contains only I and P frames.
> How can I throw the P-frames away, without taking the CPU time to
> decode them?
> Thanks, Rusty Waters

- ------------------------------------------------------------------------------
Confidentiality Notice: The information contained in this transmission is legally privileged and confidential, intended only for the use of the individual(s) or entities named above. This email and any files transmitted with it are the property of Pelco. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any review, disclosure, copying, distribution, retention, or any action taken or omitted to be taken in reliance on it is prohibited and may be unlawful. If you receive this communication in error, please notify us immediately by telephone call to +1-559-292-1981 or forward the e-mail to administrator at pelco.com and then permanently delete the e-mail and destroy all soft and hard copies of the message and any attachments. Thank you for your cooperation. 
- ------------------------------------------------------------------------------

More information about the ffmpeg-devel mailing list