[FFmpeg-devel] [PATCH] Add DPX decoder rev-9

Diego Biurrun diego
Mon May 25 10:24:23 CEST 2009


On Mon, May 25, 2009 at 08:54:12AM +0200, Jimmy Christensen wrote:
> 
> --- libavcodec/dpx.c	(revision 0)
> +++ libavcodec/dpx.c	(revision 0)
> @@ -0,0 +1,182 @@
> +/*
> +static unsigned int read32(const uint8_t **ptr, int is_big)
> +{
> +	unsigned int temp;
> +	if(is_big)

if (

> +		temp = AV_RB32(*ptr);

tabs, more below

> +#define RED10(x) ((x & 0xFFC00000) >> 22)
> +#define GREEN10(x) ((x & 0x003FF000) >> 12)
> +#define BLUE10(x) ((x & 0x00000FFC) >> 2)

This would be more readable aligned.

> +static av_cold int dpx_init(AVCodecContext *avctx)
> +{
> +}
> +
> +static av_cold int dpx_end(AVCodecContext *avctx)
> +{
> +}

The canonical names for these functions are decode_init and decode_end.

Diego



More information about the ffmpeg-devel mailing list