[FFmpeg-devel] [PATCH] png parser

Diego Biurrun diego
Wed May 27 18:46:13 CEST 2009


On Wed, May 27, 2009 at 04:52:32PM +0200, Peter Holik wrote:
> > On Wed, May 27, 2009 at 03:38:02PM +0200, Peter Holik wrote:
> >>
> >> --- /dev/null
> >> +++ b/libavcodec/png_parser.c
> >> @@ -0,0 +1,95 @@
> >> +                pc->frame_start_found = 0;
> >> +                pc->state64 = 0;
> >
> > align
> >
> >> +        *poutbuf = NULL;
> >> +        *poutbuf_size = 0;
> >> +
> >> +    *poutbuf = buf;
> >> +    *poutbuf_size = buf_size;
> >
> > ditto
> 
> ??
> 
> instead of "pc->frame_start_found = 0;"
> 
> i shoud write "pc->frame_start_found=0;" ?

No, vertically align the = for better readability:

*poutbuf      = NULL;
*poutbuf_size = 0;

*poutbuf      = buf;
*poutbuf_size = buf_size;

Diego



More information about the ffmpeg-devel mailing list