[FFmpeg-devel] [PATCH] another stab at improved dv probe

Baptiste Coudurier baptiste.coudurier
Tue Sep 29 20:19:19 CEST 2009

On 9/29/09 3:17 AM, Reimar D?ffinger wrote:
> On Sun, Sep 27, 2009 at 10:17:56PM +0200, Michael Niedermayer wrote:
>> On Sun, Sep 27, 2009 at 10:10:09PM +0200, Reimar D?ffinger wrote:
>>> On Sun, Sep 27, 2009 at 10:02:10PM +0200, Michael Niedermayer wrote:
>>>>> but that is likely not such a great idea due to possibly
>>>>> breaking things too much.
>>>> i dont remember breakages in any other video decoder or parser that searches
>>>> for a startcode if one is missing at the expected pos ...
>>> Video maybe not, but see just the current situation where mpeg files with AC3
>>> are recognized as AC3 files. That kind of thing I mean.
>> so there is a bug in the ac3 probe, did you report that?
> No, because I saw a bug report about it. Can't find it anymore though...
>> i would guess copy&  pasting the thresholds and scores from mp3 probe
>> might fix it ...
> Maybe, if I manage to find the report I'll look into it (does anyone
> else seeing the report? It was about ffmpeg-created files not recognized
> by ffmpeg).
> And I finally applied this patch, at least for what I can tell it
> doesn't make anything worse.

FYI One user reported a problem in -user:

And here's a sample video clip:


It was taken from a Sony dv camera with dvgrab. Same problem comes up
with clips that have been deinterlaced with ffmpeg and packaged to an
.avi file.

One more sample to test.

Key fingerprint                 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
FFmpeg maintainer                                  http://www.ffmpeg.org

More information about the ffmpeg-devel mailing list