[FFmpeg-devel] Fix libx264

Robert Swain robert.swain
Wed Feb 3 14:33:14 CET 2010

On 03/02/10 14:23, Felipe Contreras wrote:
> Anyway, even when I manage to compile and install it, I get this run-time error:
> [libx264 @ 0x8117a40]broken ffmpeg default settings detected
> [libx264 @ 0x8117a40]use an encoding preset (vpre)

This is obfuscation on libx264's side to avoid people encoding using 
FFmpeg with bad settings.

> Apparently '-vpre default' does the trick. But why isn't 'default' the default?

Patch welcome for this. As I recall, Michael suggested we could do this 
(autoload the default preset if existing) for per-codec defaults, though 
it's not necessarily the ideal approach. Something using AVOption was 
proposed by Baptiste and seems to be a better route.


More information about the ffmpeg-devel mailing list