[FFmpeg-devel] [PATCH][0.5] libx264.c backport

Jason Garrett-Glaser darkshikari
Mon Feb 15 09:59:01 CET 2010

On Mon, Feb 15, 2010 at 12:02 AM, Reinhard Tartler <siretart at tauware.de> wrote:
> Hi,
> Find attached a propsed patch to backport libavcodec/libx264.c.
> Features:
> ?- supposed to work with x264 API versions from 65 to 84
> ?- tested with API version 67 (built statically), encoding works fine
> ?- tested with API version 84 (built dynamically in form of a debian
> ? package), encoding works fine
> ?- work is heavily based on work by Jason
> ?- the "patch" is actually based on the libx264.c version currently in
> ? trunk. It is nevertheless presented in form of a diff against
> ? branches/0.5. When reviewing, please make sure to diff against trunk
> ?- some (most?) presets have been updated
> Left questions:
> ?- do we want to have this backport in branches/0.5 at all? (I think so)
> ?- how does this updated libx264 wrapper work with the updated presets
> ? but compiled against API version 65/67?

Some notes about this:

1) It should work just fine with older x264 APIs

2) I explicitly designed the patch to support all x264 APIs between 65
and today, with a minimum of ifdefs.  Note I did _not_ design the
patch to require the minimum amount of _changes_ from 0.5.  As I don't
care at all about 0.5, let alone its svn history, my goal was to make
the best code possible, not the best patch.

Dark Shikari

More information about the ffmpeg-devel mailing list