[FFmpeg-devel] Fix libx264

Felipe Contreras felipe.contreras
Tue Feb 23 23:54:31 CET 2010

2010/2/23 M?ns Rullg?rd <mans at mansr.com>:
> Felipe Contreras <felipe.contreras at gmail.com> writes:
>> They all support -l${library} don't they? Otherwise the current
>> "require ?libx264 x264.h x264_encoder_encode -lx264 -lm" wouldn't
>> work. Therefore they all support -lpthread, or whatever pkg-config
>> throws.
> Yes, all compilers I know of support -llib, but they do *NOT* all
> support -pthread, -pthreads, -Kthreads, etc.

If they support -llib; they support -lpthread, -lpthreadGC2,
-lpthreadGC2 -lwsock32, -lpthreadGC2 -lws2_32, or whatever x264 was
compiled with.

>> No. I have a Fedora system in my PC, and I can use gcc or clang. Same
>> system, different compiler.
> You are very narrow-minded.

And you just did an ad hominem assertion without any argument, that
doesn't provide any value to the discussion.

Felipe Contreras

More information about the ffmpeg-devel mailing list