[FFmpeg-devel] [PATCH] Add an RTSP muxer

Martin Storsjö martin
Mon Jan 4 17:32:35 CET 2010


On Mon, 4 Jan 2010, Diego Biurrun wrote:

> >                      ff_rdt_parse_close(rtsp_st->transport_priv);
> >                  else
> >                      rtp_parse_close(rtsp_st->transport_priv);
> >              }
> > +            }
> >              if (rtsp_st->rtp_pb)
> >                  url_fclose(rtsp_st->rtp_pb);
> >              else if (rtsp_st->rtp_handle)
> 
> The indentation of the closing brace is off.

Ah, that is due to the workings of git diff -w...

> Also I think this would
> be more readable if you merged the else and the if line.

True, that helped a bit. Reformatted version attached.

> > From 20f92d556b98b5f9a51932c10a1e97a8351a56e3 Mon Sep 17 00:00:00 2001
> > From: Martin Storsjo <martin at martin.st>
> > Date: Mon, 4 Jan 2010 16:42:17 +0200
> > Subject: [PATCH 24/24] Add an RTSP muxer
> > 
> > --- a/libavformat/rtsp.c
> > +++ b/libavformat/rtsp.c
> > @@ -44,7 +44,7 @@
> >  
> > -#if CONFIG_RTSP_DEMUXER
> > +#if CONFIG_RTSP_DEMUXER || CONFIG_RTSP_MUXER
> >  static int tcp_read_packet(AVFormatContext *s, RTSPStream **prtsp_st,
> >                             uint8_t *buf, int buf_size);
> >  static int rtsp_read_reply(AVFormatContext *s, RTSPMessageHeader *reply,
> 
> All those #ifdefs make me think that it's time to split this file.

It's quite large, yes, but I think the best split in that case would be 
sdp demuxer vs rtsp stuff (the parts used by ony either the rtsp muxer or 
demuxer is quite small compared to the rest) - and if I recall correctly, 
the sdp demuxer was scheduled for removal anyway?

// Martin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0019-Create-RTPMuxContext-objects-as-private-transport-fo.patch
Type: text/x-diff
Size: 2744 bytes
Desc: 
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100104/1fc7430e/attachment.patch>



More information about the ffmpeg-devel mailing list