[FFmpeg-devel] [PATCH] RealAudio 14.4 decoder: remove incorrect av_log() call

Francesco Lavra francescolavra
Tue Jan 5 15:00:53 CET 2010

On Tue, 2010-01-05 at 13:05 +0100, Vitor Sessak wrote:
> > The attached patch fixes this by removing that av_log() call; also,
> I'm not sure this is the correct fix. Can you upload the file that 
> triggered this to incoming (as described in the "bug reports" page)? Do 
> you know if the file is corrupted? IMO, if this is never reached in a 
> valid file, fixing the warning would be more appropriate than removing 
> it (and for that you would need adding a pointer to avctx in the 
> RA144Context struct).

Actually I don't have any file which triggers that error, I just spotted
this bug browsing the code.
I guess I should tell the whole story: I'm trying to write a RealAudio
14.4 encoder, and I think the function eval_refl() in the decoder would
be useful for encoding too, so I thought it could be moved to a common
file and used by both the decoder and the encoder; before doing that,
though, the third argument (RA144Context pointer) should be either
removed or changed to something more generic (like AVCodecContext).
The attached patch adds a pointer to avctx in the RA144Context struct
and fixes the av_log() call.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: ra144.patch
Type: text/x-patch
Size: 1496 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100105/fa8d9fe6/attachment.bin>

More information about the ffmpeg-devel mailing list