[FFmpeg-devel] decoding MPEG4 ASP video on iPhone (armv6, armv7)

michelle211 at comcast.net michelle211
Tue Jan 19 16:00:58 CET 2010


First a thankyou with the help of this maillist I was able to compile and get ffplay to work with various formats 

mpg, avi and mp4. 

turning off all arm optimizations and disabling posix memalign. 

But there is a problem still. 

At first it looks like the picture is very pixulated , but looking more closely it seems to be somekind of scaling issue. any ideas. 


----- Original Message ----- 
From: "M?ns Rullg?rd" <mans at mansr.com> 
To: "FFmpeg development discussions and patches" <ffmpeg-devel at mplayerhq.hu> 
Sent: Wednesday, January 13, 2010 4:48:42 PM GMT -05:00 US/Canada Eastern 
Subject: Re: [FFmpeg-devel] decoding MPEG4 ASP video on iPhone (armv6, armv7) 

Jason Garrett-Glaser <darkshikari at gmail.com> writes: 

> On Wed, Jan 13, 2010 at 9:11 AM, <michelle211 at comcast.net> wrote: 
>> When I play an avi or mpg with ffplay I get a green distorted video. 
>> much like what is described here. 
>> http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2009-December/079791.html 
> Just speculation, but this might be related to the fact that the 
> iPhone/iPod compilers ignore the ARM ABI and don't maintain 8-byte 
> stack alignment, which some functions might assume. 

That was my initial thought too, but I can't see any mpeg2/4-related 
functions that would need any specific stack alignment. A few h264 
functions do, and they align it manually. 

M?ns Rullg?rd 
mans at mansr.com 
ffmpeg-devel mailing list 
ffmpeg-devel at mplayerhq.hu 

More information about the ffmpeg-devel mailing list