[FFmpeg-devel] [PATCH] urlconcat protocol

Michele Orrù maker.py
Sat Jan 30 23:35:56 CET 2010


fixed.


> > +    for (i = 0; *filename; i++) {
> [...]
> > > +    fail:
> >
> > This is not a good name, since this also manages the case where err =
> > 0, I suggest "end" instead.
>
> Oh and if you prefer a simple:
> for (...) {
>   if (...) {
>       err = ...;
>       break;
>   }
> }
>
Yep, I prefer this (that's my first patch).


> > +    size_t                  length;   ///< number of cat'ed urls
>
> ditto, s/urls/nodes/
>
> > +    size_t                  current;  ///< index  of currently read node
> > +};
> > +
> > +static int urlconcat_open(URLContext *h, const char *filename, int
> flags)
>
> filename is too generic, please use url.
>
>
>
Changed in "uri" (that's in http.c, gopher.c, ...).


> > +        fn = av_realloc(fn, len);
>
> node_url looks like a better name.
>
I don't agree: it's confusing; upath should be ok.



MMh, I don't like line 80:
 80         uri += len + strspn(uri+len, AV_CAT_SEPARATOR);
should i split this in 2 lines?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: uconcatp2.patch
Type: application/octet-stream
Size: 6481 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100130/b6190c5c/attachment.obj>



More information about the ffmpeg-devel mailing list