[FFmpeg-devel] [PATCH] move put_v from nutenc.c and make it public in avio.h and aviobuf.c
Thu Jul 8 00:42:30 CEST 2010
Michael Chinen <mchinen at gmail.com> writes:
> 2010/7/8 M?ns Rullg?rd <mans at mansr.com>:
>> Since this is a public header, wouldn't an av_ prefix be appropriate?
> Okay, I don't really understand when ff_ should be used (there are
> several functions in avio.h with this ff_ prefix)
> also the related ff_get_v already existed in avio.h.
We should strive to remove inconsistencies, not add to them.
> so if av_ is the correct prefix, would the following be acceptable?
> Patch 1: rename all put_v to av_put_v, get_length to av_get_v_length,
> and ff_get_v to av_get_v
> Patch 2: move av_put_v and av_get_v_length to avio.h/aviobuf.c
Fine with me.
mans at mansr.com
More information about the ffmpeg-devel