[FFmpeg-devel] [RFC] libavfilter audio framework - split patches

Michael Niedermayer michaelni
Sat Jul 17 21:28:30 CEST 2010


On Sat, Jul 17, 2010 at 09:22:55PM +0200, Stefano Sabatini wrote:
> On date Friday 2010-07-16 01:01:39 -0700, S.N. Hemanth Meenakshisundaram encoded:
> > On 07/16/2010 01:00 AM, S.N. Hemanth Meenakshisundaram wrote:
> >> On 07/16/2010 12:58 AM, S.N. Hemanth Meenakshisundaram wrote:
> >>> On 07/15/2010 04:52 AM, S.N. Hemanth Meenakshisundaram wrote:
> >>>> On 07/14/2010 07:51 AM, Michael Niedermayer wrote:
> >>>>> [...]
> >>>>> to elaborate on this, we need patches that apply to svn.
> >>>>> you can send a patch series so that patch n depends on patches 0..n-1
> >>>>> to be applied before it.
> >>>>> but if patch x (x<n) is changed due to discussions all later patches
> >>>>> must be rebased on the new code. We dont apply bad patches and then
> >>>>> apply fixes on top.
> >>>>>
> >>>>>    
> >>>
> >>> [...]
> >>>
> >>> Am sending the series of patches again with the changes pointed out  
> >>> earlier. [...]
> >
> > This is for formats enum to int and AV_PERM movement.
> 
> Applied the AV_PERM movement part.
> 
> Please regenerate the patch against latest SVN.
> 
> > diff --git a/libavfilter/avfilter.h b/libavfilter/avfilter.h
> > index c8db36f..50b558e 100644
> > --- a/libavfilter/avfilter.h
> > +++ b/libavfilter/avfilter.h
> > @@ -71,7 +71,7 @@ typedef struct AVFilterBuffer
> >  {
> >      uint8_t *data[4];           ///< picture data for each plane
> >      int linesize[4];            ///< number of bytes per line
> > -    enum PixelFormat format;    ///< colorspace
> > +    int format;                 ///< colorspace
> 
> Update docs, that may say: colorspace or sample format
> 
> Also I'm not very happy about the use of an int. What about something
> like this:
> 
> struct AVFilterBuffer
> {
>    enum AVMediaType type;
>    ...
> 
>    union {
>        enum PixelFormat  video_format;
>        enum SampleFormat audio_format;
                                ^^^^^^^
unneeded?


>    } format;
>    ...
> }
> 
> ?

no oppinion, its just bikeshed

[...]
> > -AVFilterFormats *avfilter_make_format_list(const enum PixelFormat *pix_fmts)
> > +AVFilterFormats *avfilter_make_format_list(const int *fmts)
> >  {
> >      AVFilterFormats *formats;
> >      int count;
> 
> Maybe we could have a sort of generalization of the format concept.
> Something along the line of:
> 
> typedef struct {
>     enum AVMediaType type;    
>     union {
>         enum SampleFormat audio_format;
>         enum PixelFormat  video_format;
>     } format;
> }
> 
> Opinions?

all that for an int?
isnt that overkill?

[...]
-- 
Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

If you really think that XML is the answer, then you definitly missunderstood
the question -- Attila Kinali
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100717/bf43aa73/attachment.pgp>



More information about the ffmpeg-devel mailing list