[FFmpeg-devel] [PATCH] restoring binary compatibility with ffmpeg 0.5

Reimar Döffinger Reimar.Doeffinger
Sun Jun 6 23:56:19 CEST 2010

On Sun, Jun 06, 2010 at 10:32:19PM +0100, M?ns Rullg?rd wrote:
> Michael Niedermayer <michaelni at gmx.at> writes:
> >> so it will still break compatibility to some previous versions.
> >
> > do you assume this or have you tested this?
> It changes the name of the symbol.  Anything linked against current
> libavcodec will fail after this change.

Well, I at least just assumed this.
I expect (but I don't know) that adding an extra .symver will "solve" this
for gcc+gas even without the extra entry in the version script.
We'd then be down to only breaking compatibility on some platforms and
only to some versions (not to 0.5).

More information about the ffmpeg-devel mailing list