[FFmpeg-devel] x264 encoding over RTP and playing in VLC

Dominik Tomczak dominiktomczak
Fri Jun 11 11:29:58 CEST 2010


I have just tried. I have still the same problem. Video looks like there:

I use Cygwin build of ffmpeg 0.5.1 with libx264. The same result I get with
MinGW build. I haven't checked yet the build of Linux version.
The cmd line is:
$  ffmpeg -i c:/Download/movie.avi -an -vcodec libx264 -vpre normal -b 1000k
-f rtp rtp://localhost:5000

generated sdp file is (session.sdp):
o=- 0 0 IN IP4
t=0 0
s=No Name
a=tool:libavformat 52.31.0
c=IN IP4 localhost
m=video 5000 RTP/AVP 96
a=rtpmap:96 H264/90000
a=fmtp:96 packetization-mode=1

I start vlc by cmd line:
vlc session.sdp

Any ideas?

On Fri, Jun 11, 2010 at 11:21 AM, Luca Abeni <lucabe72 at email.it> wrote:

> On 06/11/2010 10:50 AM, Dominik Tomczak wrote:
>> Hello
>> I'm developing my own software for encoding the raw RGB24/32 video into
>> x264
>> and stream it using RTP to VideoLanPlayer (VLC). I use libavcodec and
>> libavformat. The problem is that I can play the video correctly neither
>> using ffmpeg tool nor using my tool.
>> Could you point me to some samples of ffmpeg code where x264 encoding and
>> RTP muxing is done?
>> When I use ffmpeg with command line:
>>  ffmpeg -i c:/movie.avi -an -vcodec libx264 -vpre normal -b 1000k -f rtp
>> rtp://
> You forgot "-re". And remember that to play the stream you have to save
> the SDP in a .sdp file, and start vlc with "vlc <SDP file>".
> After you do that, it'll work (I just tried).
>                        Luca
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-devel

Dominik Tomczak
Software Engineer

More information about the ffmpeg-devel mailing list