[FFmpeg-devel] [PATCH] Fix segfault in x11grab when drawing Cursor on Xservers that don't support the XFixes extension

Brenden Bain brenden.bain
Wed Jun 23 11:39:25 CEST 2010

2010/6/22 M?ns Rullg?rd <mans at mansr.com>:
> Michael Niedermayer <michaelni at gmx.at> writes:
>> On Tue, Jun 22, 2010 at 10:41:59PM +1000, Brenden Bain wrote:
>>> On Tue, 2010-06-22 at 12:08 +0100, M?ns Rullg?rd wrote:
>>> > Brenden Bain <brenden.bain at gmail.com> writes:
>>> >
>>> > > Reformatted and changed information message printing when XFixes not
>>> > > available to "Unable to query cursor shape. Using "arrow" mouse
>>> > > cursor."
>>> >
>>> > I would apply just the checks for the extension being present first,
>>> > and add the fallback static image afterwards.
>>> >
>>> Sorry, its not 100% clean to me what you mean here. Do you mean two
>>> patches? If you want two patches the simplest fix is probably to just do
>>> a "!= NULL" check.
>> i dunno about mans but i would like to see the crash fixed and once thats
>> done any new features could be considered depending on how widespread the
>> need for them is.
> I meant to query the extension and set nomouse if it's not available.
> Error checking when fetching the cursor should also be added.

Thanks for clearing things up. I have attached the modified patch.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: x11_segfault_fix.patch
Type: text/x-patch
Size: 2018 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100623/c7db25d4/attachment.bin>

More information about the ffmpeg-devel mailing list