[FFmpeg-devel] [PATCH] restoring binary compatibility with ffmpeg 0.5

Måns Rullgård mans
Tue Jun 29 03:07:51 CEST 2010

Frank Barchard <fbarchard at google.com> writes:

> On Mon, Jun 28, 2010 at 3:35 PM, M?ns Rullg?rd <mans at mansr.com> wrote:
>> Frank Barchard <fbarchard at google.com> writes:
>> > This patch breaks chromium linux builds, which use gyp to build ffmpeg.
>> WTF is gyp and why do you use it to build ffmpeg?
>> Whatever the answer, this is the wrong place to kick up a fuss about it.
> Its a build system that apparently doesnt support the symver trick.

Why don't you use the excellent build system included with ffmpeg instead?
It would need less work from you *and* do the right thing.

> /usr/bin/ld: error: symbol av_free_packet has undefined version LIBAVFORMAT_52
> Is there a way to disable the compatibility code?  The ifdef is done like
> this:
> libavformat/utils.c
> HAVE_SYMVER is auto detected.

If you don't build the code with the same tools you showed configure,
you deserve every bit of trouble you encounter.  Do not expect anyone
here to "help" you.

M?ns Rullg?rd
mans at mansr.com

More information about the ffmpeg-devel mailing list