[FFmpeg-devel] [PATCH] rename -vfilters to -vf
Tue May 11 20:39:42 CEST 2010
On date Tuesday 2010-05-11 11:18:29 -0700, Baptiste Coudurier encoded:
> Hi Stefano,
> On 05/11/2010 11:13 AM, Stefano Sabatini wrote:
> >On date Tuesday 2010-05-11 10:42:40 -0700, Baptiste Coudurier encoded:
> >>$subject, simpler shorter.
> >Currently we have:
> >-filters -> show supported filter list
> >-vfilters -> insert a video filter graph
> >I don't like much the "v" in vfilters since the filterchain hopefully
> >will include also audio filters.
> >So when I have no particular preference for the color of the bikeshed
> >in this case I'd like to have something more future-proof. The obvious
> >choice would be "filters" but that option is already taken. So we
> >could have something of the kind -filter_graph, or -fg abbreviated.
> >And if we want to keep both long and short option we can do that, like
> >it is done for -h/-help (not sure it is a good idea though, as it may
> >confuse users).
> Well, mplayer have been using -af and -vf for years now.
> If -vfilters would list video filters and -afilters would list audio
> filters, it would find that nice, personally, especially if the
> filter list becomes long.
That's if we want to keep the audio and video and text paths
separated, what if we want inter-media filters? In this case having a
unique filter graph option looks/sounds/reads better.
FFmpeg = Fanciful Fundamental Meaningless Peaceful Elegant Governor
More information about the ffmpeg-devel