[FFmpeg-devel] [PATCH 07/12] Use less confusing names for the parameters used by the eval API.
Thu May 13 00:41:18 CEST 2010
On date Sunday 2010-05-09 23:41:33 +0200, Michael Niedermayer encoded:
> On Sun, May 09, 2010 at 06:42:11PM +0200, Stefano Sabatini wrote:
> > On date Monday 2010-04-12 16:43:52 +0200, Michael Niedermayer encoded:
> > > On Mon, Apr 12, 2010 at 12:37:40AM +0200, Stefano Sabatini wrote:
> > > > "var" is better than "const" for something which is meant to be
> > > > a name assuming variable values inside an expression.
> > >
> > > its constant within en expression, we have variables within expressions
> > > too.
> > That's true but I found this confusing, if they are called "constants"
> > the user will ask why their values need to be specified for each
> > evaluation. Calling that just variables should make apparent that they
> > are meant to possibly change at each evaluation.
> const in C and const here have quite similar semantics, i dont see
> the problem
Well I don't mind so much, so patch dropped.
FFmpeg = Frightening and Friendly Majestic Pure Erudite God
More information about the ffmpeg-devel