[FFmpeg-devel] [PATCH] Default to using libraries when enabled

Alex Converse alex.converse
Sat May 22 05:52:38 CEST 2010

2010/5/21 M?ns Rullg?rd <mans at mansr.com>:
> Baptiste Coudurier <baptiste.coudurier at gmail.com> writes:
>> Hi guys,
>> On 05/20/2009 05:20 PM, David Conrad wrote:
>>> Hi,
>>> This changes the order of initialization so that external libraries that
>>> are enabled are used by default over native codecs. My main motivation
>>> in moving these is to be able to have the ogg and mkv muxers default to
>>> encoding via libvorbis if it's enabled; currently, specifying
>>> CODEC_ID_VORBIS will use the native encoder regardless, which is much
>>> worse quality.
>> I'd like to revive this thread.
>> It's been more than a year, and nothing has been done on the native
>> vorbis encoder to improve it's quality.
>> While the patch is questionable for all codecs, I think it is not for
>> vorbis.
>> Can we please make everything so libvorbis is used by default when it
>> is compiled in ?
> This can be easily done, and I think it should be done.

I sadly agree :(

More information about the ffmpeg-devel mailing list