[FFmpeg-devel] [PATCH] Use hierarchic names convention (prefix them with av_expr) for eval API.
Thu Nov 4 22:02:20 CET 2010
On date Thursday 2010-11-04 00:20:25 +0100, Michael Niedermayer encoded:
> On Wed, Nov 03, 2010 at 08:59:33PM +0100, Stefano Sabatini wrote:
> > More grep-friendly and more consistent with the rest of the FFmpeg
> > API.
> > ---
> > libavutil/avutil.h | 8 ++++
> > libavutil/eval.c | 96 ++++++++++++++++++++++++++++++++++-----------------
> > libavutil/eval.h | 45 +++++++++++++++++++++---
> > 3 files changed, 111 insertions(+), 38 deletions(-)
> probably ok, maybe wait a day or 2 before applying in case someone has better
> ideas for the names
BTW I'm a bit unconfortable with the "and" in
av_expr_parse_and_eval(), maybe av_expr_parse_eval() should be just
fine (and shorter).
But I have no strong feeling on this so opinions and other bikeshed
color proposals are welcome.
Anyway I'll apply the patch the next week if no one has further
FFmpeg = Fostering & Funny Majestic Power Exciting Gem
More information about the ffmpeg-devel