[FFmpeg-devel] What demuxers are needed for these decoders

Jason Garrett-Glaser darkshikari
Wed Nov 10 23:24:50 CET 2010

On Wed, Nov 10, 2010 at 2:17 PM, phil hefferan <wdef200 at gmail.com> wrote:
> Agreed this was the wrong list, sorry.
>> What would be the minimum list of demuxers that need to be enabled in
>> FFmpeg
>> > to support use of the above codecs for playing streams via gst-ffmpeg in
>> > Totem? ?My plan is first to disable all unneeded demuxers and muxers so
>> we
>> > can then analyze potential patent issues on what remains.
>> I know of no muxer or demuxer with any supposed patent issues.
>> I had a hunch this might have been the case but thought people here might
> be likely to hear about contentious ones.
>> You need practically every demuxer enabled regardless, unless you're
>> going to tell your users "you can only use MP4, and not MKV" or
>> something silly like that.
> Ok on those more popular formats, but there are some fairly obscure demuxers
> that maybe it wouldn't hurt to turn off if these aren't in our use case.
> I've just been informed that google turn off nearly everything in their
> libffmpegsumo for Chrome ie seem to be taking a conservative approach. I
> think we will emulate their approach, test and see if anything breaks.

This is because Chrome explicitly only wants to support one or two
container formats.  It isn't about patent risk.

Dark Shikari

More information about the ffmpeg-devel mailing list