[FFmpeg-devel] [PATCH 8/8] Replace "depth" with "nb_bits" in the header of avcodec_pix_fmt_string().
Sun Nov 21 22:24:42 CET 2010
On date Sunday 2010-11-21 00:00:33 +0100, Stefano Sabatini encoded:
> On date Friday 2010-11-19 00:37:38 +0100, Stefano Sabatini encoded:
> > On date Tuesday 2010-11-16 23:57:44 +0100, Michael Niedermayer encoded:
> > > On Mon, Nov 15, 2010 at 03:04:28PM +0100, Stefano Sabatini wrote:
> > > > On date Monday 2010-11-15 14:07:00 +0100, Michael Niedermayer encoded:
> > > > > On Mon, Nov 15, 2010 at 12:15:15PM +0100, Stefano Sabatini wrote:
> > > > >
> > > > > why?
> > > >
> > > > bits per pixel != PixFmtInfo.depth
> > > >
> > > > less confusing
> > >
> > > well, iam not sure if "nb" is less confusing and people will know it means
> > > number, especially non native english speakers
> > > Also nb_bits is quite ambigous
> > > number (used) bits of all samples (like 15 for rgb15)
> > > or number bits each pixel occupies (like 16 for rgb15)
> > > sadly i dont really have a good suggestion either ...
> > oh let's stop this bikeshed, "depth" is not clear as well and is just
> > plain wrong in this case, also "nb_bits" is in the sense of -pixfmts
> > and of av_get_bits_per_pixel(), and I don't think an header or the
> > name of a function has to explain *all*, just be a meaningful
> > indication of what it points to.
> I'll apply in few days.
FFmpeg = Forgiving & Foolish MultiPurpose Enhancing Glue
More information about the ffmpeg-devel