[FFmpeg-devel] [PATCH] libmp3lame: don't check unused function in detection

Rafaël Carré rafael.carre
Wed Oct 6 18:48:32 CEST 2010

On Wed, 6 Oct 2010 17:50:03 +0200
Michael Niedermayer <michaelni at gmx.at> wrote:

> On Wed, Oct 06, 2010 at 01:13:32PM +0200, Rafa?l Carr? wrote:
> > hip_decode_init() isn't used by the wrapper, and can be absent from
> > the library if lame was configured with --disable-decoder (like it
> > is done for windows builds of VLC)
> > 
> > Unfortunately this also removes the way to detect a libmp3lame more
> > recent than the buggy 3.98.2
> i dont belive that there is no other way to detect the version

belive it or not that's all we have

lame provide a get_lame_version() function but of course it's not
usable when cross compiling

[fun at wai ~]% lame -v|& head -1
LAME 64bits version 3.98.4 (http://www.mp3dev.org/)
[fun at wai ~]% grep 98 /usr/include/lame/lame.h
[fun at wai ~]% 

If some people still have lame 3.98.2 then too bad for them, FFmpeg
would have built happily before r25128 anyway.
Also in "[PATCH] float values for libmp3lame quality" [1], James says he
hasn't "seen this in a while so it looks as though most have updated."

[1] http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2010-September/096815.html

? Rafa?l Carr? ?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20101006/3fb08550/attachment.pgp>

More information about the ffmpeg-devel mailing list