[FFmpeg-devel] [PATCH 1/1] Reimplement ff_img_copy_plane() as av_img_copy_plane() in libavcore, and deprecate the old function.
Sun Sep 5 20:59:17 CEST 2010
On date Sunday 2010-09-05 18:59:34 +0200, Michael Niedermayer encoded:
> On Sat, Sep 04, 2010 at 02:59:50PM +0200, Stefano Sabatini wrote:
> > On date Saturday 2010-09-04 13:45:30 +0200, Michael Niedermayer encoded:
> > > On Sat, Sep 04, 2010 at 10:52:08AM +0200, Stefano Sabatini wrote:
> > > > On date Saturday 2010-09-04 01:27:41 +0200, Michael Niedermayer encoded:
> > [...]
> > > > > if its used by a differnt lib then it is external and part of the ABI/API
> > > > > it also then requires all the versioning, major and minor and soname bumping
> > > > > if it changes. Thus the API has to be reviewed more throughout than if its
> > > > > just internal where we can change it trivially
> > > >
> > > > So tell what's wrong with the following and possibly suggest what you
> > > > prefer instead, thus avoiding guessloops to me.
> > >
> > > the doxy is poor, the name is poor
> > > call it av_image_copy_plane() for example
> > >
> > > and doxy could be
> > >
> > > Copy image plane from src to dst.
> > > That is, copy "height" number of lines of "bytewidth" bytes each.
> > > The first byte of each successive line is seperated by *_linesize bytes.
> > Doxy fixed.
> > As for the name I already explained that imgutils.h API is not using a
> > hierachical naming scheme, so av_copy_image_plane() is consistent with
> > the rest of the API (and imho more resembling the English language ->
> > more readable).
> and i prefer an hierachical naming sheme here, its not a strong preferance
> but it has its nice features like you can grep for things easier
av_.*image works as well.
My other concerns is consistency, sorry to bother but I'd hate to have
a mixed style API.
FFmpeg = Fundamentalist Fancy Multimedia Picky Elfic Game
More information about the ffmpeg-devel