[FFmpeg-devel] [PATCH] swscale: add generic yuv2yuv wrapper function
Thu Sep 16 03:42:26 CEST 2010
On Tue, Sep 14, 2010 at 12:39 PM, Michael Niedermayer <michaelni at gmx.at> wrote:
> On Sat, Sep 11, 2010 at 02:15:39AM -0300, Ramiro Polla wrote:
>> This is a patch series that cleans the yuv2yuv functions inside
>> rgb2rgb.c a bit (and removes their global function pointers).
>> Now I'm stuck in a bikeshed issue. There is one rgb2yuv function in
>> there (rgb24toyv12). So "yuv2yuv_func" and "Yuv2YuvFunc" don't sound
>> too great anymore. How should it be named?
> rgb->yuv needs a bit more work anyway as there are several yuv types but
> it hardcodes one
I don't really understand what you mean here. Are you talking about
yuv2rgb.c or rgb24toyv12()?
> about the patch that looks good after a quick look and i assume its tested
Is this for the whole patchset or just the addition of yuv2yuv_func
More information about the ffmpeg-devel