[FFmpeg-devel] [PATCH] configure: check yasm/nasm for working pextrd opcode

Dave Yeo daveryeo
Sun Feb 6 07:21:24 CET 2011

On 02/05/11 09:58 pm, Anssi Hannula wrote:
> NASM versions older than 2.08 fail to build ffmpeg with several
> "error: operation size not specified" errors but this is not caught in
> configure.
> Fix that by checking if "pextrd [eax], xmm0, 1" works in configure.

Thanks, I've been wondering how to check for an up to date version of nasm.
For the record I verify that we need a fairly up to date nasm to build 
and the patch looks good (untested).

More information about the ffmpeg-devel mailing list