[FFmpeg-devel] av_ prefixes in avformat.h

Ronald S. Bultje rsbultje
Sun Feb 6 17:48:37 CET 2011


On Sun, Feb 6, 2011 at 9:46 AM, Anton Khirnov <anton at khirnov.net> wrote:
> this patch series adds av_ prefixes to the last unprefixed functions in
> avformat.h. With it, the only non av_/avformat_/avf_ (wtf does it
> mean?)

Misnomer, let's eventually rename that to avformat_sdp_create() also.

> stuff in avformat.h will be some ffserver hacks, which I'm not
> sure what to do about. Ideas?

Same, probably. "Does not belong in avformat" simply isn't true, it's
there, has been there forever and isn't going anywhere anytime soon...


More information about the ffmpeg-devel mailing list