[FFmpeg-devel] AVX assembly for ffmpeg

Reimar Döffinger Reimar.Doeffinger
Tue Feb 15 21:27:41 CET 2011

On Tue, Feb 15, 2011 at 08:12:13PM +0000, M?ns Rullg?rd wrote:
> Daniel Kang <daniel.d.kang at gmail.com> writes:
> > I have been asked to write AVX assembly for ffmpeg. This will require
> > porting x264's x86inc.asm file with the AVX abstraction layer. Ideally, I
> > would like to bump the yasm version, as it is already checked for pextrd
> > (SSE4). However, is this is not permissible, I can see if the AVX compile
> > flag can be set conditionally, based on the yasm version.
> How recent a yasm version is required, and how hard is it to make it
> conditional?

Note that I promised to not burden other people with it, but I'd appreciate
it if you could also look into/try not to break nasm :-)

More information about the ffmpeg-devel mailing list