[FFmpeg-devel] ffmpeg license requirement

Reinhard Tartler siretart
Thu Feb 17 09:17:19 CET 2011

On Thu, Feb 17, 2011 at 07:47:24 (CET), Kan Hu wrote:

> Hi, all,
> I'm a engineer working for linaro.org.
> I'm currently work on aac encoder optimization for arm.
> I have measure the performance data for the currently aac encoder in ffmpeg
> and it seems the performance is not good enough for the real-time encoding
> requirement on arm, and also there's a aac encoder used in android which
> performance is better but it's Apache licensed.
> I'm wondering the license requirement for the ffmpeg, is it possible for
> ffmpeg to start with android one?

Depends on your understanding of 'start'. A wrapper like the
opencore-amr wrapper would be fine, replacing the aac code with
something derived from android's apache licensed aac encoder would not.


Reinhard Tartler, KeyID 945348A4

More information about the ffmpeg-devel mailing list