[FFmpeg-devel] [PATCH] movenc: convert put_tag() into ffio_wfourcc().

Peter Ross pross
Sat Feb 26 15:14:49 CET 2011


On Fri, Feb 25, 2011 at 04:10:26PM -0800, Baptiste Coudurier wrote:
> Hi,
> 
> On 02/25/2011 02:36 PM, Ronald S. Bultje wrote:
> >---
> >  libavformat/movenc.c |    6 +++---
> >  1 files changed, 3 insertions(+), 3 deletions(-)
> >
> >diff --git a/libavformat/movenc.c b/libavformat/movenc.c
> >index 93d6ce9..57a6d11 100644
> >--- a/libavformat/movenc.c
> >+++ b/libavformat/movenc.c
> >@@ -1241,16 +1241,16 @@ static int mov_write_tapt_tag(ByteIOContext *pb, MOVTrack *track)
> >      int64_t pos = url_ftell(pb);
> >
> >      avio_wb32(pb, 0); /* size */
> >-    put_tag(pb, "tapt");
> >+    ffio_wfourcc(pb, "tapt");
> >
> >      avio_wb32(pb, 20);
> >-    put_tag(pb, "clef");
> >+    ffio_wfourcc(pb, "clef");
> >      avio_wb32(pb, 0);
> >      avio_wb32(pb, width<<  16);
> >      avio_wb32(pb, track->enc->height<<  16);
> >
> >      avio_wb32(pb, 20);
> >-    put_tag(pb, "enof");
> >+    ffio_wfourcc(pb, "enof");
> >      avio_wb32(pb, 0);
> >      avio_wb32(pb, track->enc->width<<  16);
> >      avio_wb32(pb, track->enc->height<<  16);
> 
> This name is extremely ugly.

+1

put_tags and get_be32, et al were more readable imho.

Also, why not have a general put_tag for writing tags of any length,
and provide additional optimised ones for specific lengths.  e.g.
   
ff_put_tag(pb, "TI:songtitle");
ff_put_tag4(pb, "RIFF");

-- Peter
(A907 E02F A6E5 0CD2 34CD 20D2 6760 79C5 AC40 DD6B)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20110227/c0b03c56/attachment.pgp>



More information about the ffmpeg-devel mailing list