[FFmpeg-devel] Operation not permitted when reading RTSP stream

Stas Oskin stas.oskin
Mon Jan 24 14:53:11 CET 2011


I'm trying to diagnose yet another RTSP device problem (this time from Axis,
which according to all senses should have been working fine - but alas), and
encountering a really strange problem:

* Decoding video works fine
* Saving video to disk as-is produces garbage
* Re-streaming video as-is produces garbage

Trying to save / re-stream video via ffmpeg binary produces the following

[rtp @ 0x1d16ee30] pts < dts in stream 0
av_interleaved_write_frame(): Operation not permitted

It seems as the presentation time arrives earlier then decoder time, which
causes this error. I tried passing the igndts and genpts flags, but with
same result.
In my code I'm ignoring this situation and just using the PTS, which might
be the reason why it works out for me only for the decoding.

Any idea why this limitation present in FFMPEG, and if it related to
saving/re-streaming issues I'm having?

Thanks in advance.

More information about the ffmpeg-devel mailing list