[FFmpeg-devel] Broken MJPG decoding and the old patch that fixes it

Flemming Frandsen dren.dk at gmail.com
Thu Jul 21 22:14:31 CEST 2011

Hi, I've recently started using a webcam that outputs MJPG directly,
which is very nice because that allows me to save a bunch of CPU
transcoding and I can stream 720p30 to with no problem.

The problem is that the resulting file cannot be decoded by ffmpeg
because the camera inserts some padding that's not usually there when
others generate MJPEG.

Fortunately Logitech had a guy develop a patch over a year ago which
was posted on this very mailing list, so one would think that I ought
to be able to play back my video today, but it seems that the  patch
was never merged because it didn't do the right thing, as evidenced

If anyone is interested I've put up a couple of examples of borken and
working mjpg here:

What I'd like to know is:
1) Seeing as the patch actually fixes the problem and it's less than
20 lines of code that only impacts mjpg decoding, could someone take
pitty and merge the patch already?

2) Failing that, could someone explain how ff_er_add_slice() and
ff_er_frame_end() works and how they can be applied to this problem?

Flemming Frandsen - YAPH - http://osaa.dk - http://dren.dk/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ffmpeg_mjpeg_restart_marker_patch.diff
Type: text/x-diff
Size: 2002 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20110721/1c052214/attachment.bin>

More information about the ffmpeg-devel mailing list