[FFmpeg-devel] [GSoC] [RFC] Abstract AVFilterFormats to AVRefCountedList for reuse
michaelni at gmx.at
Thu Jun 2 05:46:57 CEST 2011
On Wed, Jun 01, 2011 at 09:32:49AM +0300, Mina Nagy wrote:
> ----- Original message -----
> > On Mon, May 30, 2011 at 11:36:22PM +0200, Stefano Sabatini wrote:
> > > On date Monday 2011-05-30 12:00:01 +0300, Mina Nagy Zaki encoded:
> > > > AVRefCountedList will be used for lists of supported formats and
> > > > channel layouts. There is a problem currently with chlayouts, they
> > > > are int64 while formats are int32. I could not determine why
> > > > chlayouts are 64 bit, but trying to change them will break API/ABI.
> > > > This means AVRefCountedList will have to support both. After
> > > > discussion with Stefano I think simply having a
> > > > avfilter_refcounted_list_make32() will do. Video filters will have
> > > > to use that since they will store PixelFormat lists, which are
> > > > enums and hence 32bit.
> > >
> > > Or alternatively use int64_t and convert the enum pix_fmts arrays to
> > > int64_t arrays.
> > >
> > > Michael, Peter?
> > maybe the functions/fields could be named better but i dont have
> > specific ideas
> Which part needs changing? The namespace (AVFilter* instead of AV*) or the 'refcounted' name itself, or perhaps 'list' ('set' is more apropos), or does it just need to be shortened (av_rclist_make, etc) ?
nothing needs changing its just that somehow refcounted sounds a
bit obscure compared to formats.
maybe its just the best term that exists, i dunno
this is not an objection to the patch
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Those who are best at talking, realize last or never when they are wrong.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 198 bytes
Desc: Digital signature
More information about the ffmpeg-devel