[FFmpeg-devel] [PATCH] avio: add avio_skip function
Ronald S. Bultje
Fri Mar 4 12:41:12 CET 2011
On Fri, Mar 4, 2011 at 5:41 AM, Peter Ross <pross at xvid.org> wrote:
> This is a substitute for the url_fskip function that was deprecated by
> commit 0300db8ad778a194b4a8ec98f6da3de5b41c46ee. avio_fskip is provided to
> improve demuxer code readability. It distinguishes the act of skipping over
> unknown or irrelevant bytes from the standard avio_seek operation.
> On Thu, Mar 03, 2011 at 03:16:19PM +0100, Michael Niedermayer wrote:
>> On Thu, Mar 03, 2011 at 08:26:50AM -0500, Ronald S. Bultje wrote:
>> > Hi,
>> > On Thu, Mar 3, 2011 at 6:37 AM, Peter Ross <pross at xvid.org> wrote:
>> > > This is a substitute for the url_fskip function that was deprecated by
>> for the record id like to repeat that a function is better for this
> I am happy either way.
> Here is an patch with avio_skip as a function.
Sorry for responding slowly. I am fine with it as a macro. I think
Mans preferred the macro as well. The theoretical advantages of the
skip-as-a-function approach don't exist because gcc doesn't inline the
More information about the ffmpeg-devel