[FFmpeg-devel] Fate under qemu

Peter Ross pross at xvid.org
Thu Mar 24 13:51:58 CET 2011

On Thu, Mar 24, 2011 at 10:42:22PM +1100, Peter Ross wrote:
> On Thu, Mar 24, 2011 at 01:01:48AM +0100, Michael Niedermayer wrote:
> > Hi
> > 
> > Did anyone had some luck with running fate under qemu?
> > A few days ago i cross compiled ffmpeg to mips,sparc,powerpc and arm
> > (which worked fine)
> > but i had no luck getting anything to run under debians qemu,
> > powerpc just hit a invalid instruction (yes i disabled alitivec)
> > and arm got stuck or took unexpectedly long.
> That problem is repeatable here using recent qemu git build. An ffmpeg
> binary compiled on my PPC/Debian machine, will result in 'Invalid instruction'
> when attempting to run on x86 host with qemu-ppc. The binary works
> fine on the real hardware.

Ok. Problem solved.

The invalid instruction was 'mfvrsave' inserted by gcc in ffmpeg.c/transcode().
One needs to add --disable-altivec to the configure line to prevent gcc from
using Altivec optimizations.

-- Peter
(A907 E02F A6E5 0CD2 34CD 20D2 6760 79C5 AC40 DD6B)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20110324/895f3bbe/attachment.asc>

More information about the ffmpeg-devel mailing list