[FFmpeg-devel] [PATCH] Fix check for new enough CrystalHD library

Reimar Döffinger Reimar.Doeffinger at gmx.de
Mon Mar 28 19:43:47 CEST 2011

On Mon, Mar 28, 2011 at 11:34:38AM +0200, Gwenole Beauchesne wrote:
> If an older libcrystalhd is installed, the current configure check
> will validate it but will fail to build FFmpeg since there were some
> API changes.
> I see two ways to check this:
> 1) Check for the new libcrystalhd_version.h file
> 2) Check for the new DtsCrystalHDVersion() function
> (2) is implemented in the attached patch. Along with an addition to
> make sure crystalhd support is disabled if check_lib fails.

I assume the same "|| disable" should be added for vaapi as well?

More information about the ffmpeg-devel mailing list