[FFmpeg-devel] can't get it to work on CentOS

Matteo Sisti Sette matteosistisette at gmail.com
Mon May 23 23:51:06 CEST 2011

I'm seeing that libopencore seems to be missing, but I do have the 
library installed (and had it when I compiled ffmpeg) and I did compile 
it with --enable-libopencore-amrnb --enable-libopencore-amrwb

With the versions of ffmpeg that work (ubuntu and CentOS):

  $ ffmpeg -formats | grep amr

  DE amr             3GPP AMR file format
  DEA    libopencore_amrnb OpenCORE Adaptive Multi-Rate (AMR) Narrow-Band
  D A    libopencore_amrwb OpenCORE Adaptive Multi-Rate (AMR) Wide-Band

With the version that does not work (CentOS, the one that I have just 
compiled from source):

  $ ffmpeg -formats | grep amr

  DE amr             3GPP AMR file format

What should I do to get libopencore support (besides installing 
libopencore and using the abovementioned --enable options)?


On 05/23/2011 10:47 PM, Michael Niedermayer wrote:
> On Mon, May 23, 2011 at 10:14:34PM +0200, Matteo Sisti Sette wrote:
>> Hi,$ ffmpeg -formats | grep amr
>> I need help to get ffmpeg to work on a CentOS server.
>> I can't understand why it has to be so difficult.
>> I first tried installing it with yum:
>> yum install ffmpeg
>> but when I tried to convert some amr files to mp3 I got this error:
>> [amrnb @ 0x626e90] dtx mode not implemented. Update your FFmpeg version
>> to the newest one from SVN. If the problem still occurs, it means that
>> your file has a feature which has not been implemented.If you want to
>> help, upload a sample of this file to
>> ftp://upload.ffmpeg.org/MPlayer/incoming/ and contact the ffmpeg-devel
>> mailing list.
>> repeated a lot of times.
>> That didn't make much sense, because on another CentOS box I have a
>> version of ffmpeg that a friend of mine compiled several years ago which
>> can decode the same files without any issue (and so does the version for
>> ubuntu that I got with apt get on yet another box).
>> However I thought the package from the repository must be outdated and
>> hence I followed the instructions I found here
>> http://www.pawprint.net/news/index.php?action=view&nid=105
>> getting the latest version from SVN and compiling it from scratch.
> please see
> http://www.ffmpeg.org/download.html
> for where and how to get the latest version
> If you still have problems after that, please submit a bug report to
> http://ffmpeg.org/trac/ffmpeg
> [...]
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

More information about the ffmpeg-devel mailing list