[FFmpeg-devel] "--enable-avfilter-lavf" switch not working for v0.8.7

Peter B. pb at das-werkstatt.com
Tue Nov 22 11:46:11 CET 2011


I've been successfully compiling FFmpeg versions 0.5 and 0.6, as well as
the current git-version, with the following commandline:

./configure --prefix=/usr/local --enable-gpl --enable-nonfree
--enable-postproc --enable-swscale --enable-avfilter --enable-pthreads
--enable-bzlib --enable-libmp3lame --enable-libvorbis --enable-libxvid
--enable-zlib --enable-libopenjpeg --enable-decoder=png
--enable-encoder=png --enable-avfilter-lavf --enable-libfaad && make
clean && make

However, version 0.8.7 (from the tar.bz2 archive) throws the following
error when running configure:

Unknown option "--enable-avfilter-lavf".
See ./configure --help for available options.

If that switch would be deprecated, why does it work for the current

Thanks in advance,

More information about the ffmpeg-devel mailing list