[FFmpeg-devel] manually hacked configure options increase h264 decoding speed significantly

madshi madshi at gmail.com
Thu Oct 20 14:31:19 CEST 2011

2011/10/20 Reimar Döffinger <Reimar.Doeffinger at gmx.de>
> It should also need -fomit-frame-pointer, and it makes more
> sense to just look in config.log which options were used and
> why it failed.

config.log says:

# ./configure --enable-shared --disable-static --enable-pthreads --arch=x86
--cpu=i686 --extra-cflags='-march=i686 -mfpmath=sse -mmmx -msse


BEGIN /tmp/ffconf.FxAVoQLM.c
    1    #include <signal.h>
    2    static void sighandler(int sig){
    3        raise(SIGTERM);
    4    }
    5    int main(void){
    6        signal(SIGILL, sighandler);
    7        signal(SIGFPE, sighandler);
    8        signal(SIGSEGV, sighandler);
    9    #ifdef SIGBUS
   10        signal(SIGBUS, sighandler);
   11    #endif
   12        {     volatile int i=0;
   13        __asm__ volatile (
   14            "xorl %%ebp, %%ebp"
   15        ::: "%ebp");
   16        return i; }
   17    }
END /tmp/ffconf.FxAVoQLM.c
-U__STRICT_ANSI__ -march=i686 -mfpmath=sse -mmmx -msse -DPTW32_STATIC_LIB
-march=i686 -std=c99 -fno-common -fomit-frame-pointer -c -o
/tmp/ffconf.mjvtCbzL.o /tmp/ffconf.FxAVoQLM.c
C:/DOKUME~1/LOKALE~1/LOKALE~1/Temp/ffconf.FxAVoQLM.c: In function 'main':
C:/DOKUME~1/LOKALE~1/LOKALE~1/Temp/ffconf.FxAVoQLM.c:17:1: error: bp cannot
be used in asm here
check_asm ebx_available ""::"b"(0)

Do I have to call "configure" with -O3 and -fomit-frame-pointer
to get a chance to have EBP automatically activated? If I try
to do that, I'm getting this:

configure --enable-shared --disable-static --enable-pthreads --arch=x86
--cpu=i686 --extra-cflags='-o3 -fomit-frame-pointer -march=i686 -mfpmath=sse
-mmmx -msse -DPTW32_STATIC_LIB'

"ERROR: MinGW runtime version must be >= 3.15."

Best regards, Mathias.

More information about the ffmpeg-devel mailing list