[FFmpeg-devel] video corruption using h264 hw decoders

Reimar Döffinger Reimar.Doeffinger at gmx.de
Sat Oct 29 13:08:48 CEST 2011

On Sat, Oct 29, 2011 at 11:40:16AM +0200, Rainer Hochecker wrote:
> >Iam not sure what statement from whom you refer to, but the sizes
> >must be large enough to cover all writes to the surface and the
> >linesizes must be sufficiently aligned to allow SIMD code to function
> >at full speed. That is not just SIMD from the software decoder when
> >used but also possible filters a user application might want to
> >apply to the output afterwards
> >If you need some croping details exported, this can be done though i
> >do not understand why you have this need and everyone else seems not
> >to have it.
> >[...]
> >--
> >Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
> We see this problem mainly on BBC channels which broadcast additional lines
> at the bottom of a frame. So far I have not seen any material which had
> set crop_right. I would be interested in trying such a movie.
> Looking at the vdpau decoder API it does not take paramters like linesize
> or mb_width so I guess it assumes that the alloceted video surface has to
> match the encoded frame size.

What kind of API are you using anyway? The only one I know uses a mixer,
and you never even get to see the internal decode surfaces in any way,
just the output surfaces, but at that point already all the scaling,
cropping, colour space conversion etc. has already happened (well, at
least as far as any of that was requested).

More information about the ffmpeg-devel mailing list