[FFmpeg-devel] [PATCH 2/4] lavf/utils: use AV_NOWARN_DEPRECATED in compatibility code.

Michael Niedermayer michaelni at gmx.at
Thu Sep 15 17:40:18 CEST 2011

On Thu, Sep 15, 2011 at 08:59:02AM +0200, Nicolas George wrote:
> L'octidi 28 fructidor, an CCXIX, Michael Niedermayer a écrit :
> > if you think this is better than the warnings then no objection
> Thanks for the reviews. It happened to me several times to miss real
> warnings among the flood of "deprecated" warnings, so I think this is indeed
> better.

something like colorgcc can be used to colorize warnings
i had a old patch somewhere that colors them according to "severness"
("upstream" never reacted to that patch)
also i had ccache +colorgcc + ffmpeg working a long time ago with some
symlinks somehow

iam not saying this is an alternative to reducing warnings but i think
it was quite helpfull to spot higher priority warnings amongth the flood
of lower ones


Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

I have often repented speaking, but never of holding my tongue.
-- Xenocrates
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20110915/dbafc49b/attachment.asc>

More information about the ffmpeg-devel mailing list